Problem configuring CoA

DILLIOTT Tony Tony.Dilliott at
Sat Aug 1 01:22:08 CEST 2009

Hi *
I am trying to get COA server running with 2.1.6. 
After downloading and successfully installing on Redhat Linux setup, I
have not been able to get COA to work at all.
After a lot of investigation, I have found a discrepency with the
clients.conf file in the tar file I downloaded in 2.1.6 and a version I
see on the -net. Specifically, the following lines are missing from the
file in the tar file compared to an example I found on the web:
#  A pointer to the "home_server_pool" OR a "home_server" 
#  section that contains the CoA configuration for this
#  client.  For an example of a coa home server or pool,
#  see raddb/sites-available/originate-coa
# coa_server = coa
After going through the C source code I see that this missing coa_server
pointer is in fact referenced in the source code.
I have now added this, but still I have issues.
I originally commented out the coa pool because I don't want pools for
SO, my problem is that even after adding the following line to my
clients.conf file to match the pointer file to the example host_server
config in originate-coa file,:
coa_server = localhost-coa
I still get the following error when I run radiusd -Xx :
/usr/local/etc/raddb/clients.conf[30]: No such home_server or
home_server_pool "localhost-coa"
So now I uncomment the stuff to do the coa pool, and now I get the
following debug output
### Loading Realms and Home Servers ###### :
proxy server {
home_server localhost {
home_server_pool my_auth_failover {
realm {
realm LOCAL {
/usr/local/etc/raddb/site-enabled/originate-coa[121]: home_server
"localhost-coa" does not exist.
Given the file discrepency I have already uncovered, I assume I must be
missing something else but I cannot find out what. I appreciate any help
as soon as possible.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list