rlm_perl / libtool / libltdl problem

Alan DeKok aland at deployingradius.com
Tue Aug 18 09:49:48 CEST 2009

Garber, Neal wrote:
> This does, in fact, work; but, isn’t very satisfying as a permanent
> solution.  I believe that libtool and libltdl were updated during the
> install of the patch and this is the source of the problem.  I’m now
> running FreeBSD 7.2 with libltdl-2.2.6a & libtool-2.2.6a (they were at
> 2.2.5 before).

  Did I mention that I hate libtool and libltdl?  They're close to
*causing* more problems than they solve.

> Is anyone aware of any compatibility issues with libtool/libltdl 2.2.6a
> and FreeRADIUS?  

  They both suck.  Depending on the phase of the moon, they might not
even cause the *build* process to fail.

> Anyone have a more permanent solution that avoids the LD_PRELOAD ugliness? 

  Educate the libltdl / libtool developers so that they write software
that works?

> I’ve tried rebuilding FR from the port with no subsequent patches and
> received the same result (FR wouldn’t start without the LD_PRELOAD).  I
> also tried using the portdowngrade port to downgrade libtool & libltdl
> back to 2.2.5 which didn’t seem to have this problem.  However, it only
> displayed 2.2.6a (i.e., I couldn’t downgrade).  rlm_perl seems to be
> pointing to the proper libperl.so as shown below:

  Yeah... isn't that nice?  And libltdl *still* can't get it right.

  I mean... what the heck?

  I actually started removing libltdl a while ago.  See
src/main/modules.c.  Look for WITHOUT_LIBLTDL.  I'll bet that if you
spent a bit of time hacking the source, you could get it to build && run
*without* libltldl.  At that point, the stupid "can't load library"
issues will go away.

  Alan DeKok.

More information about the Freeradius-Users mailing list