sqlippool : undefined symbol: rlm_sql_query

Sebastian Krieger skr at ts.tsimail.de
Mon Feb 9 15:34:40 CET 2009


I want to get freeradius running with the sqlippool module and mysql 
backend on Ubuntu 8.04 LTS Server.
Everything works so far, but it seems still impossible to enable the 
sqlippool on Debian based systems.

At first I tried the freeradius 1.1.7-1build4 packages supplied by the 
distribution, but then I always received the following error:

freeradius: symbol lookup error: /usr/lib/freeradius/rlm_sqlippool.so: 
undefined symbol: sql_get_socket

After that I gave the backport packages of version 2.1.0 a try, because 
I have read somewhere that this error should be solved since version 
2.0.4. But unfortunately I had the same result with it.


Now I tried to compile freeradius version 2.1.3 on this server and to 
build a fresh deb package with success, but using sqlippool now results 
into a slightly different error message.

freeradius: symbol lookup error: 
/usr/lib/freeradius/rlm_sqlippool-2.1.3.so: undefined symbol: rlm_sql_query

In this message a patch to this problem is mentioned.

And here someone relinked rlmsqlippool to rlm_sql to get rid of this issue.

What should I do to get sqlippool working? I don't know how to relink 
the it.

Thanks a lot.


There seems to be a syntax error at line 24 in 
/usr/local/etc/raddb/sql/mysql/ippool.conf. At the end of the line "\" 
is missing.

including configuration file /usr/local/etc/raddb/sql/mysql/ippool.conf
/usr/local/etc/raddb/sql/mysql/ippool.conf[24]: Expecting section start 
brace '{' after "AND nasipaddress"
Errors reading /usr/local/etc/raddb/radiusd.conf

  WHERE expiry_time <= NOW() - INTERVAL 1 SECOND \
  AND nasipaddress = '%{Nas-IP-Address}'"

More information about the Freeradius-Users mailing list