FW: upgraded from freeradius 1.1.3 to 2.0.4

Alan DeKok aland at deployingradius.com
Thu Feb 19 12:51:55 CET 2009

Frank van den Diepstraten wrote:
> Well, I didn't expect this kind of reactions. I tried to give as
> much information as I had.

  You didn't expect to be told that automatic upgrades across major
versions wasn't supported?

> First of all I upgraded to the newest
> packages of debian etch before I did a dist-upgrade to lenny.
> With the latest version of etch it still worked. The latest
> version in debian lenny is the 2.0.4 which I am running now.
> I do use the groupreply option (but no groupcheck option
> because the check has been done already in the usercheck option)

  That is not a supported configuration.  See doc/rlm_sql, especially
section 1, item #5.  It explains how the server works.

  The groupcheck && groupreply configuration items work together to
obtain a result.  You can't simply delete one, and expect the other to
work properly.

  Alan DeKok.

More information about the Freeradius-Users mailing list