ippools and Pool-Name

up at 3.am up at 3.am
Wed Jun 3 17:25:17 CEST 2009

On Wed, 3 Jun 2009, Alan DeKok wrote:

>  Because you don't have the GDBM libraries or header files.

Ok, I installed those, and while I was at it, installed the latest 
radiusd.  The first error I got involved the "experimental" 
raddb/sites-available/control-socket which was included in the old
radiusd.conf: $INCLUDE sites-enabled/.  I moved the file and radiusd 
started and worked as it did before.

However, when I uncomment my ippool statement, I now get this:

  Module: Linked to module rlm_ippool
  Module: Instantiating users_pool
   ippool users_pool {
 	session-db = "$(raddbdir)/db.ippool"
 	ip-index = "$(raddbdir)/db.ipindex"
 	key = "%{NAS-IP-Address} %{NAS-Port}"
 	range-start =
 	range-stop =
 	netmask =
 	cache-size = 251
 	override = yes
 	maximum-timeout = 0
rlm_ippool: Failed to open file $(raddbdir)/db.ippool: No such file or 
/usr/etc/raddb/radiusd.conf[1824]: Instantiation failed for module 
/usr/etc/raddb/sites-enabled/default[337]: Failed to find module 
/usr/etc/raddb/sites-enabled/default[314]: Errors parsing accounting 
Errors initializing modules

If I understand correctly, if I am running radiusd as root, shouldn't it 
simply create the db. files itself when started?  I tried a "touch 
raddb/db.ippool" but it changed nothing.

Again, thanks for your patience...

James Smallacombe		      PlantageNet, Inc. CEO and Janitor
up at 3.am							    http://3.am

More information about the Freeradius-Users mailing list