[rad] Re: pseudo-newbie exec scripts and session-time

Charles Gregory cgregory at hwcn.org
Thu Jun 11 22:42:28 CEST 2009

Okay, I'm banging my head up against the expected proverbial wall.
Please remember I'm stuck with old 1.x version..... on Centos

I'm trying to get a script to execute and set the 'Session-Timeout'
value. I've defined the script thusly:

         exec timecalc {
                 wait = yes
                 program = "/usr/local/etc/radius_timecalc %{User-Name}..."
                 input_pairs = request
                 output_pairs = reply
                 # packet_type = Access-Accept

(I've tried it with and without the packet_type....)

I've tried placing just "timecalc" into the post-auth and 
alternately the auth sections. I don't get any errors,
but the script does not run... (I have the script touch a file
to prove it runs, and it doesn't happen).

I tried using the sytax:
      update reply {
And also tried:
      update reply {
               Session-Time := "200"

and got 'rcode' errors under post-auth and 'syntax' errors in auth.
I might have mised a magic combination.

Anyone care to tell me the exact syntax for making this script run
on an access-accept?

- Charles

More information about the Freeradius-Users mailing list