freeradius2 exited when running in multi-server mode

CHui CHui at
Thu Sep 17 01:12:47 CEST 2009

I am testing freeRadius 2.1.6 running on FreeBSD kernel 7.2 i386.  The
freeradius2 is configured to do ldap authentication and authentication
worked without any issue.   However, radiusd exited unexpectedly during a
simple stress test.  I used a sh script to issue the "radtest user pwd . &"
command in a loop to simulate radius client authentication request. When
freeradius2 was invoked with the following command "radiusd -d
/usr/operator/raddb/", thus running in multi-server mode, it exited within a
few minutes. There was no trace of runtime error nor coredump (did try
allow_core_dump=yes).  If I run freeradius2 in single-server mode with the
command "radiusd -s -d /usr/operator/raddb/", it held up quite well.  I
don't mind running freeradius2 in single-server mode as it appears to handle
the load quite well during the test.  Is it recommended though?  Any
suggestion on work around? 


More information about the Freeradius-Users mailing list