Dictionary problem preventing startup..(AudioCodes)

mark smith radius at keypad.org
Tue Sep 29 22:26:30 CEST 2009


Trying to set up some new devices (AudioCodes MP118) to authenticate, but the dictionary entries the mfr. says is for FreeRadius doesn't quite work.

Using FreeRadius v. 2.1.6 on Mac OS X

The users entries they say to try looks like this:

john Auth-Type := Local, User-Password == "qwerty"
Service-Type = Login-User,
ACL-Auth-Level = ACL-Auth-SecurityAdminLevel
or on another user, it's set lower as:
ACL-Auth-Level = ACL-Auth-UserLevel

#AudioCodes VSA dictionary
VENDOR AudioCodes 5003
ATTRIBUTE ACL-Auth-Level 35 integer AudioCodes
VALUE ACL-Auth-Level ACL-Auth-UserLevel 50
VALUE ACL-Auth-Level ACL-Auth-AdminLevel 100
VALUE ACL-Auth-Level ACL-Auth-SecurityAdminLevel 200

But that above entry causes this:
Errors reading dictionary: dict_init: /opt/local/etc/raddb/dictionary[39]: unknown option "AudioCodes"

For kicks, I have tried leaving the dictionary entry out and tried Login-User by itself (doesn't authenticate) as well as Administrative-User for Service Type but all that does is authenticate, but at a level too low to do anything.

Needless to say, commenting out the dictionary entries just cause the daemon to choke on the users file... And vice versa.

http://www.audiocodes.com/filehandler.ashx?fileid=36358 is the guide I was using for reference.

Thanks in advance for any pointers.


More information about the Freeradius-Users mailing list