Attribute not passing to NAS?

mikal mpm at
Tue Dec 7 08:12:36 CET 2010

Hi Rob,

Nope, no EAP with a Captive Portal.  But I just configured a VNS with EAP,
so I see what you're talking about.  But I think that the problem is that
the Filter-ID isn't being sent in the Access-Accept, and I'm pretty sure
that that's where it should be.  I didn't play with my radius configuration
yet, but I suspect that you (we?) need to modify your config so that the
Filter-ID attribute is sent with the Access-Accept.  All of the packets that
you see between the first Access-Request and the Access-Accept have to do
with setting up the tunnels, certificate validation, etc.

So yep, I see what you're seeing, but I think it's simply a small config
change on the Freeradius side to get it working correctly.  I just don't
know off-hand what needs to be changed, hopefully get a chance to poke
around tomorrow. 

Rob Yamry wrote:
> Hey Mikkal-
>  Im not sure if my last few emails went through the list... I got a msg
> stating they were pending approval since they were too long.  I kept
> digging
> into this and I came across the eapol_test utility:
>  I tried running that to
> take
> the client and NAS out of the process.  As far as I can tell, it all looks
> like fine.  Even with a default install of 2.1.10 (and another test using
> new certs with the required OIDs for XP clients:
> I still get those 9 requests.  Are you using EAP?
>   Is anybody else following this that can/test verify that they get the
> same
> responses as I do.
> Thanks-
> Rob
> -
> List info/subscribe/unsubscribe? See

View this message in context:
Sent from the FreeRadius - User mailing list archive at

More information about the Freeradius-Users mailing list