Proxying inner requests from EAP-TTLS

Martin Merkel martin.merkel at
Tue Jun 8 00:56:18 CEST 2010

Am 07.06.2010 23:28, schrieb Alan DeKok:
>   See the 'v2.1.x' branch on for a fix.
Thank you, Alan, for your quick reply and fix. I compiled the latest
version with your modifications, but unfortunately it still doesn't work.

The error message changed to:

WARNING: No previous template for proxy socket.  Source IP address may
be chosen by the OS
Failed binding to proxy address port 0: Cannot assign
requested address
Failed binding to new proxy socket
Failed to create a new socket for proxying requests.
ERROR: Failed inserting request into proxy hash.
ERROR: Failed to proxy request 5

I tried adding a "listen { type=proxy }" block in radiusd.conf and
setting the src_ipaddr in proxy.conf. Neither changed the output.

What I just noticed is that is the ip address of the switch
where the request is coming from. Of course it can't bind to that
address. Something is wrong there.

The setup looks like this:
- local AAA:
- home AAA:
- switch:

The only occurence of in my config is in clients.conf:

localaaa:/usr/local/radius/2.1.x/etc/raddb# grep -r .
./clients.conf:    ipaddr        =

Kind regards,

More information about the Freeradius-Users mailing list