Welcome to the "Freeradius-Users" mailing list

Tim Sylvester tim.sylvester at networkradius.com
Thu Jul 7 07:41:49 CEST 2011

This doesn't specifically address your problem, but you should use a more
recent version of FreeRADIUS. Try downloading FreeRADIUS 2.1.10 or 2.1.11
from www.freeradius.org.







freeradius-users-bounces+tim.sylvester=networkradius.com at lists.freeradius.or
[mailto:freeradius-users-bounces+tim.sylvester=networkradius.com at lists.freer
adius.org] On Behalf Of silambarasan sundar
Sent: Wednesday, July 06, 2011 10:34 PM
To: freeradius-users at lists.freeradius.org
Subject: Re: Welcome to the "Freeradius-Users" mailing list




I am very new to radius server and installed
"freeradius-1.1.2-sol10-sparc-local". While starting the server I am seeing
the below error message.  I did not modify any configuration file. Just
running the radius after installation. 


Please help me in solving  this issue.


I tried the freeradius-1.1.7-sol10-sparc-local , I got the same error.



bash-3.00# radiusd -X

Starting - reading configuration files ...

reread_config:  reading radiusd.conf

Config:   including file: /usr/local/etc/raddb/proxy.conf

Config:   including file: /usr/local/etc/raddb/clients.conf

Config:   including file: /usr/local/etc/raddb/snmp.conf

Config:   including file: /usr/local/etc/raddb/eap.conf

Config:   including file: /usr/local/etc/raddb/sql.conf

 main: prefix = "/usr/local"

 main: localstatedir = "/usr/local/var"

 main: logdir = "/usr/local/var/log/radius"

 main: libdir = "/usr/local/lib"

 main: radacctdir = "/usr/local/var/log/radius/radacct"

 main: hostname_lookups = no

 main: snmp = no

 main: max_request_time = 30

 main: cleanup_delay = 5

 main: max_requests = 1024

 main: delete_blocked_requests = 0

 main: port = 0

 main: allow_core_dumps = no

 main: log_stripped_names = no

 main: log_file = "/usr/local/var/log/radius/radius.log"

 main: log_auth = no

 main: log_auth_badpass = no

 main: log_auth_goodpass = no

 main: pidfile = "/usr/local/var/run/radiusd/radiusd.pid"

 main: user = "(null)"

 main: group = "(null)"

 main: usercollide = no

 main: lower_user = "no"

 main: lower_pass = "no"

 main: nospace_user = "no"

 main: nospace_pass = "no"

 main: checkrad = "/usr/local/sbin/checkrad"

 main: proxy_requests = yes

 proxy: retry_delay = 5

 proxy: retry_count = 3

 proxy: synchronous = no

 proxy: default_fallback = yes

 proxy: dead_time = 120

 proxy: post_proxy_authorize = no

 proxy: wake_all_if_all_dead = no

 security: max_attributes = 200

 security: reject_delay = 1

 security: status_server = no

 main: debug_level = 0

read_config_files:  reading dictionary

read_config_files:  reading naslist

Using deprecated naslist file.  Support for this will go away soon.

read_config_files:  reading clients

read_config_files:  reading realms

radiusd:  entering modules setup

Segmentation Fault (core dumped)





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20110706/f26fdd66/attachment.html>

More information about the Freeradius-Users mailing list