No Realm in table radacct

xylakant at xylakant at
Fri Oct 19 20:43:31 CEST 2012

Hello again,

sorry for the late answer, but I tried to resolve the problem for myself 
and learnd more about the process of freeradius.

So my problem is always that the radius doesn't reply the realm of the 
authenticated user.
The server dectects the realm and knows about it ( %{Realm} ->. 
"" ).

But in the Access-Accept is not the realm attribute. I tried to update it 
manualy without success. Other attributes like 3Com-Ip-Host-Addr are 
possible to send.

Sending Access-Accept of id 188 to port 1814
    User-Name = "markus"
    MS-MPPE-Recv-Key = 
    MS-MPPE-Send-Key = 
    EAP-Message = 0x03e00004
    Message-Authenticator = 0x00000000000000000000000000000000
    3Com-Ip-Host-Addr = "123.456.789.012"
    Proxy-State = 0x323437
    Proxy-State = 0x323132

In "post-auth" of  my "default"  config:

    update reply {
        Realm = "%{Realm}"    

    update reply {
        3Com-Ip-Host-Addr = 123.456.789.012    

Here you can see the log:

I hope you can help me. Thanks Ulf

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list