Server dosn't detect any requests except from localhost

Alan DeKok aland at
Tue Apr 9 14:21:58 CEST 2013

Saeed Zanderahimi wrote:
> Here is the problem: Whenever I send a request from a radius client (I
> tried some testers, and even radtest) to my freeRadius server I get time
> out, freeRadius is running in dubuging mode and I can see that it
> doesn't receive any request whether to accept or reject. I tried the
> windows server on that LAN and my computer which is connected to VPN and
> can see the freeRadius server. (successful pinging)

  So the network is up, but you can't reach the RADIUS port.  This
usually means a firewall is blocking traffic.  Go check that.

> I used -netstat to see what IPs and ports are listening, the result was
> so I assume that it is listening to all IPs on 1812.
> whenever I try to start the server with -i and -p I get the message that
> server cannot bind on the address that I want because it is already
> listening to them on another thing. I can start the server with -i
> 172.16.150.*** which is its own address and -p 1812.

  When you start the server in debugging mode, you need to shut down any
server already running.  You haven't done that.  That's why it's saying
"address already in use".

  1) check that the firewall allows traffic to port 1812

  2) stop all servers currently running

  3) then run it in debug mode

  4) it should work

  Alan DeKok.

More information about the Freeradius-Users mailing list