compile with ldap support

Chris Taylor Chris.Taylor at
Thu Apr 11 04:15:46 CEST 2013

How do I check that I have them installed I have the openldap rpm installed. I am trying to go from an rpm build to a source build to fix a problem.


-----Original Message-----
From: at [ at] On Behalf Of Arran Cudbard-Bell
Sent: Wednesday, April 10, 2013 10:07 PM
To: FreeRadius users mailing list
Subject: Re: compile with ldap support

On 10 Apr 2013, at 21:12, Chris Taylor <Chris.Taylor at> wrote:

> What are options do I have to use to compile freeradius with ldap support turned on? I tried ./configure -with-ldap but that didn't seem to work I still get an error about not being able to find rlm_ldap. I checked the mail archives but I couldn't find anything.

It'll build it by default if you have the libldap headers installed. Check the output of configure to verify it's actually building rlm_ldap.

Arran Cudbard-Bell <a.cudbardb at> FreeRADIUS Development Team

Please contribute documentation:

"Fruity Oaty Bars, make a man out of a mouse. Fruity Oaty Bars, make you bust out of your blouse"

List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list