rlm_eap: No such sub-type for default EAP type peap

Michael kevin kevin198607 at gmail.com
Wed Nov 13 11:36:56 CET 2013

I have a problem about "rlm_eap: No such sub-type for default EAP type peap"

after I install the openssl,but the problem is still not resolved.

Now I am testing EAP authentication process by using eapol_test tool,Iwant
to write a my module for our own project to provide some AAA  functions.
Below are some steps that I did in the EAP authentication test.

I mostly followed the two sites <
and<http://deployingradius.com/scripts/eapol_test/> and a book named
<FreeRADIUS Beginner's Guide>.

all the test about <Local authentication without EAP>、<authenticate via a
remote authenticator>、<Getting the simplest EAP method into the picture:
EAP-MD5>were successed.
But when I do the <Full swing with EAP-TLS, EAP-TTLS and PEAP> test ,it

Below are  something i do about the users file and the configuration files:
1.I added a user in the users file
2.As my environment is Ubuntu10.04,my freeradius is installed using
source(./configure->make->make install),it locates at /usr/local/etc/raddb/
,I edit the eap.conf as below:
I just changed the default_eap_type = md5 to default_eap_type = peap

but then when I run radiusd -X,it turns out the below errors:
rlm_eap: No such sub-type for default EAP type peap
/usr/local/etc/raddb/eap.conf[17]: Instantiation failed for module "eap"
/usr/local/etc/raddb/sites-enabled/default[310]: Failed to load module
/usr/local/etc/raddb/sites-enabled/default[252]: Errors parsing
authenticate section.

Can anybody help me and give me some suggestions?

Thank you very much!!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20131113/4679df4d/attachment.html>

More information about the Freeradius-Users mailing list