FR3.0.1Problems with raddebug and radmin.

Palmer J.D.F. J.D.F.Palmer at
Thu Feb 27 11:21:26 CET 2014


I'm having some issues with raddebug and radmin not matching conditions.
If I run raddebug with no condition, and run a test auth an output is generated; however if I set a condition I get no output.
I've not been able to get radmin to write anything to my debug file.

I've tried a few different formats for my conditions, all to no avail.

-u user at
-u 'user at'
-u "user at"
debug condition '(User-Name == -u user at'
debug condition '(User-Name == -u 'user at')'
debug condition '(User-Name == -u "user at")'

Only raddebug with no condition produces anything, which at least proves that it is connecting to the radiusd socket.

I also note that if I set a condition within radmin, then do 'show debug condition' there is no condition active.  Whereas if I repeat this exercise on FR2.2.0 it returns my condition as expected.

Can anyone confirm that they are seeing the same behaviour?

FR 3.0.0 had an issues where radmin and raddebug would crash radiusd on exit, however that appears to be fixed in FR3.0.1

Many thanks,

Jezz Palmer
Information Services and Systems
Swansea University
Singleton Park

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list