RES: Error 1: gmake Free Radius 3.0.3 at Solaris

Rafael de Farias Meurer rafael.meurer at
Wed Jun 4 16:27:36 CEST 2014

Yes, I tried to use make and I got this error:

make: Fatal error in reader:, line 33: Unexpected end of line seen

the line is this:

32: ifeq "${raddbdir}" ""

33: raddbdir        = ${sysconfdir}/raddb

34: endif

When I comment the line 32 and 34, the error appears in another ifeq and endif line.

That's why I tried to use gmake but this two I got erro.

De: Lloyd Gill [mailto:lhg at]
Enviada em: quarta-feira, 4 de junho de 2014 11:18
Para: FreeRadius users mailing list; Rafael de Farias Meurer
Assunto: Re: Error 1: gmake Free Radius 3.0.3 at Solaris

Rafael, while I don't use the FreeRadius server on solaris (we use MS Radius, and free radius clients on our unix systems), I have compiled software for decades on Solaris without issue.  There may be some things to tweak along the way, but most things compile fine. I have traditionally used /usr/ccs/bin/make and gcc and that combination usually works well. Have you tried that yet?


From: Rafael de Farias Meurer <rafael.meurer at<mailto:rafael.meurer at>>
Reply-To: FreeRadius users mailing list <freeradius-users at<mailto:freeradius-users at>>
Date: Wednesday, June 4, 2014 at 9:12 AM
To: "'freeradius-users at<mailto:'freeradius-users at>'" <freeradius-users at<mailto:freeradius-users at>>
Subject: Error 1: gmake Free Radius 3.0.3 at Solaris

I'm trying to install free radius 3.0.3at Solaris, after I use gmake command I got this error, I tried to use make and didn't work either:

CC src/lib/cbuff.c
In file included from /home/nms/radiusTeste/freeradius-server-3.0.3/src/freeradius-devel/libradius.h:65,
                 from src/lib/cbuff.c:26:
/home/nms/radiusTeste/freeradius-server-3.0.3/src/freeradius-devel/missing.h:419:1: warning: "htonll" redefined
In file included from /usr/include/netinet/in.h:73,
                 from /usr/include/netdb.h:74,
                 from /home/nms/radiusTeste/freeradius-server-3.0.3/src/freeradius-devel/missing.h:40,
                 from /home/nms/radiusTeste/freeradius-server-3.0.3/src/freeradius-devel/libradius.h:65,
                 from src/lib/cbuff.c:26:
/usr/include/sys/byteorder.h:46:1: warning: this is the location of the previous definition
In file included from src/lib/cbuff.c:26:
/home/nms/radiusTeste/freeradius-server-3.0.3/src/freeradius-devel/libradius.h:637: error: syntax error before "func"
gmake: *** [build/objs/src/lib/cbuff.lo] Error 1

What can I do to solve this error?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list