Issue with DHCP with Wireless card

Matthew Newton mcn4 at
Wed Mar 12 22:14:22 CET 2014

On Wed, Mar 12, 2014 at 02:44:37PM -0500, Hugh McLenaghan wrote:
> I'm hoping that the issue is something simple I've done wrong or missing.

Doesn't help much, but I just tested with a WLAN card in my Linux
desktop (TP-LINK TL-WN772N, Atheros AR9271) and it worked straight
away; assigned an IP to my tablet, and saw the packets in tcpdump.

It also worked on a Netgear WLAN card, also supposedly the same
chipset, though it's not a good card. When a DHCP Discover got
through, though, the Offer was successfully sent.

I'll see if I can dig out the Pi to test, but this may take a
while as I've not fired it up for a bit.

So it doesn't look like a problem with DHCP over a wireless
interface in general.


> ----------------------------------------
> > Date: Wed, 12 Mar 2014 14:00:07 -0400
> > From: aland at
> > To: freeradius-users at
> > Subject: Re: Issue with DHCP with Wireless card
> >
> > Hugh McLenaghan wrote:
> >> Starting FreeRADIUS:Wed Mar 12 11:10:22 2014 : Info: radiusd: FreeRADIUS Version 3.1.0 (git #b71e353), for host armv6l-unknown-linux-gnu, built on Mar 12 2014 at 01:50:59
> >
> > Please use v3.0.2 branch. The "master" branch is undergoing heavy
> > development. And also use "radiusd -X". Using "-Xx" doesn't help.
> >
> > Are you running this as root? The DHCP code requires that for proper
> > operation. You should also set the "interface" entry in the listen
> > section for dhcp. That will tell it to receive / send packets on the
> > correct interface.
> >
> > Alan DeKok.
> > -
> > List info/subscribe/unsubscribe? See 		 	   		  
> -
> List info/subscribe/unsubscribe? See

Matthew Newton, Ph.D. <mcn4 at>

Systems Specialist, Infrastructure Services,
I.T. Services, University of Leicester, Leicester LE1 7RH, United Kingdom

For IT help contact helpdesk extn. 2253, <ithelp at>

More information about the Freeradius-Users mailing list