2.2.5 Compilation error

Mohd Alkhaldi alwaadalhaq at gmail.com
Sun May 4 05:39:47 CEST 2014

I tried to compile FR 2.2.5 on Solaris 10 with oracle support, when I run
make I get the following error:

gcc -I/oracle/software/adsl/freeradius-server-2.2.5
-I/oracle/software/adsl/freeradius-server-2.2.5/src -m64 -Wall
-I/oracle/software/adsl/freeradius-server-2.2.5/libltdl -D_LIBRADIUS
-I/oracle/software/adsl/freeradius-server-2.2.5/src -c base64.c -o base64.o
>/dev/null 2>&1
/oracle/software/adsl/freeradius-server-2.2.5/libtool --mode=link --tag=CC
gcc -release  \
-m64 -export-dynamic -o libfreeradius-radius.la -rpath
/oracle/software/adsl/local/lib debug.lo dict.lo filters.lo hash.lo hmac.lo
hmacsha1.lo isaac.lo log.lo misc.lo missing.lo md4.lo md5.lo print.lo
radius.lo rbtree.lo sha1.lo snprintf.lo strlcat.lo strlcpy.lo token.lo
udpfromto.lo valuepair.lo fifo.lo packet.lo event.lo getaddrinfo.lo vqp.lo
heap.lo dhcp.lo base64.lo
gcc -shared -Wl,-h -Wl,libfreeradius-radius--m64.so -o
.libs/libfreeradius-radius--m64.so  .libs/debug.o .libs/dict.o
.libs/filters.o .libs/hash.o .libs/hmac.o .libs/hmacsha1.o .libs/isaac.o
.libs/log.o .libs/misc.o .libs/missing.o .libs/md4.o .libs/md5.o
.libs/print.o .libs/radius.o .libs/rbtree.o .libs/sha1.o .libs/snprintf.o
.libs/strlcat.o .libs/strlcpy.o .libs/token.o .libs/udpfromto.o
.libs/valuepair.o .libs/fifo.o .libs/packet.o .libs/event.o
.libs/getaddrinfo.o .libs/vqp.o .libs/heap.o .libs/dhcp.o .libs/base64.o
ld: fatal: file .libs/debug.o: wrong ELF class: ELFCLASS64
ld: fatal: File processing errors. No output written to
collect2: ld returned 1 exit status

It seems that it is looking for 64bit library, But which library it is
looking for?

Alwaad Alhaq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20140504/1481b5eb/attachment.html>

More information about the Freeradius-Users mailing list