How to link to openssl if two versions of libssl are on the system, when building FreeRadius on Debian wheezy 7.4?

Rani Ahmed ranixlb at
Fri May 16 14:52:36 CEST 2014

This is what I have:
I have from Debian wheezy repository : OpenSSL 1.0.1*e* as a binary
package. Already installed on the normal location /usr/lib. => Heartbleed
I did build from tar.gz file,  OpenSSL 1.0.1*g *and installed it on
/usr/local/ . This is the default --prefix in the ./config of OpenSSL
I built freeradius using the following configure command :

./configure --with-openssl-includes=/usr/local/ssl

and without the

allow_vulnerable_openssl = yes

I still get freeradius want to run on OpenSSL 1.0.1e instead of 1.0.1g
, and of course it will refuse, then, to run beacause of the
heartbleed bug.

Also, I did tell ldconfig in /etc/ about the path
"/usr/local/ssl/lib" just to make freeradius use OpenSSL 1.0.1g , I
still get it from /usr/lib instead..

So how should I exactly link it to 1.0.1g?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list