Freeradius-Users Digest, Vol 118, Issue 30

Sander Eerdekens sander.eerdekens at
Tue Feb 17 15:39:25 CET 2015

> -----Oorspronkelijk bericht-----
> Date: Tue, 17 Feb 2015 09:17:44 -0500
> From: Arran Cudbard-Bell <a.cudbardb at>
> Subject: Re: compiling Freeradius v3 on Solaris 11
> > We are currently migrating to new servers for our freeradius setup,
> > And would like to take the opportunity to switch from freeradius v2 to
> freeradius v3 as well.
> > I am having some problems compiling freeradius v3 on Solaris 11, Though.
> > Until now we compiled Freeradius v2 on Solaris 10.
> You could take this opportunity to migrate away from solaris? :)

I am stuck on SPARC/Solaris hardware for anything unix-like.
Building is hard, but one we get it build I cannot complain. ;)

> > Now, we are trying to compile freeradius 3.0.6 on solaris 11.2 (SPARC).
> Mm that's going to be fun.

> > Is there anything I can do to help get this issue fixed?
> From previous notes/rants, you need to define -D_XOPEN_SOURCE to match
> the C standard used.

Thank, I will look into this. For now I used Alan's suggestion, which seemed to help.

> > Some other problems I ran into but managed to circumvent:
> > -       I have to use gmake, make gives an error on, line 33:
> Unexpected end of line seen
> >      Same issue as
> users/2014-June/072411.html
> > -       I tried using solaris studio's cc, here I get stuck on "checking for
> talloc.h", even though I include -- with-talloc-include-dir with configure, cc
> does not know the -isystem it seems
> Ok. Well, you're welcome to write a patch to check for -isystem to
> enable/disable it. Or use gcc/clang.

Just thought I would mentioned it (also helpful for other people trying to compile on solaris in the future),
I myself have not the knowledge to write good patches, but I am perfectly happy using this workaround, or using gcc.

> >      If I try to compile the snippet itself I get a warning that the last return
> was not reached.
> >      Is my compiler broken, of what could be the issue here?
> Hm. Fixed that. It's being extra picky.


> >      With GCC I do not have this issue, but I end up in the problem that gcc
> does not know the -KPIC option,
> >      If I adjust the source to -fPIC, I end up in the same situation above with
> the udpfromto error.
> Solaris is a complete pain to build on. I managed to do with with the ldap
> module disabled.
> -Arran

It seems with some effort, I managed to build 3.0.6 with rlm_ldap.
I do compile my own ldap libraries, I do not use the built-in solaris headers/libs.
I'll try to test if the rlm_ldap function actually works, but will have to familiarize myself with the v3 config files first.
If the rlm_ldap function actually works I will keep you up-to-date.

Thank you, Arran and Alan :)

Kind regards
Sander Eerdekens

More information about the Freeradius-Users mailing list