radwho gives an empty output

Mert Uzun uzunme at itu.edu.tr
Wed Feb 18 21:24:38 CET 2015

>> To mention my work detailly, on GNS3, I have one c7200 cisco router as
>> NAS(for administration access to router only, not to provide an
>> internet connection) and a freeradius server on ubuntu server 14.04. I
>> configured my NAS to send accounting update per one minute. In
>> /var/log/freeradius/radacct/(ip of the nas)/detail-(date), I can read a
>> txt file where some accounting infos are written but when I issue
>> "radwho" command, I can not see anything but the titles for non-written
>> accounting details.
> Read the debug output, and look for the “radutmp” module.  What does
> say when the server receives an  Accounting-Request?

Unfortunately I saw no output by radutmp module. I only saw auth_log  
outputs that prompting outputs into a txt file (I tried some  
configurations on detail.log). I think that I may have not noticed a  
useful information but I have no idea about what it is. However,  
because I configured my NAS to request accounting logouts, my server  
send accounting reply when any user log off on the NAS.

>> I also issued freeradius -X command and got "ready to process request",
>> my server can properly process authentication requests also.
> The point is to read the output *after* it says “Ready to process
> requests”.  That tells you what it’s doing when it processes

I read each row after receiving a request. I couldn't see any radutmp  
module output as I said above. At least I know what I need to focus on  

>> However, I'm not completely unsuccessful to get any output from radwho.
>> I had done some configurations on freeradius and managed to get proper
>> outputs with radwho on the same topology and system. Unfortunately, my
>> server got disfunctioned when I had tried to configure it for active
>> directory authentication. I could only recovered it by re-installing
>> then I lost and forgot what I did to use radwho.
> You should use “git” for revision control on the raddb directory. 
> helps a lot.

I should have learned this function before. Due to malfunctions on my  
computer, I lost whole topology and virtual machines but I will  
remember this advice in future thank you a lot.

>> I can't remember what I did to get radwho output before I lost whole
>> configuration and what I can't notice now.
> If you send Accounting packets which have useful session data in them,
> radwho will “just work”.

After reading this, I read my accounting configuration on the NAS. I  
suspected of a forgotten accounting command. Then I issued some  
accounting commands to apply "trial&error". Unfortunately, radwho  
didn't work again. I will continue to search for any missing  
accounting commands.

In general, those details were all caused from the previous topology  
which I lost completely recently. I will build it up again in a few  
days. After a short process of adding clients and users, I will read  
debug details as you recommend and share results. Thanks for your help.
Mert Uzun
Elektrik Mühendisliği Bölümü-2. Sınıf Öğrencisi

More information about the Freeradius-Users mailing list