Freeradius 3 and routers problem

Alan DeKok aland at
Mon Jan 19 13:44:01 CET 2015

On Jan 19, 2015, at 6:29 AM, alter1 <alter1 at> wrote:
> I have a network: 3 soho wifi routers Dlink wrt54gl, wrt320n and Asus RT-AC52U. On each is the same configuration (wifi wpa2-enterprise with radius auth on 192.168.10.x server with 1812 port and secret key for each client)

  OK.  That should be simple enough.
> Mon Jan 19 12:16:10 2015 : Auth: (80) Login OK: [test/<via Auth-Type = MSCHAP>] (from client rt-a1-1 port 0 via TLS tunnel)
> Mon Jan 19 12:17:13 2015 : Auth: (85) Login OK: [test/<via Auth-Type = EAP>] (from client rt-a1-1 port 13 cli 8c3ae3XXXXXX)
> And all works... But... Ater some period of time 30-60 minutes noone can connect to wifi on AP’s.

  That’s bad.

> I tried with alternative firmwares. Still the same.
> After tcpdump connections I have nothing... That mean. I tcpdump iface (ens160) and cannot see ANY PACKETS from any AP's to radius server…

  Then the APs are broken.  When a user logs in, the APs should start doing RADIUS.

> Problem disappear after restart freeradius (systemctl restart radiusd.service).

  Restarting FreeRADIUS doesn’t cause the APs to start sending packets.  Something else is going on.

  What happens if you reboot the APs instead of FreeRADIUS?

  Alan DeKok.

More information about the Freeradius-Users mailing list