SV: reading hosts from NAS table not working on 2.2.6?

Alexander Silveröhrt Alexander.Silverohrt at
Sun May 3 07:41:21 CEST 2015

I don't have any duplicates and i posted my config earlier. And its the same result when i only add one single host to the nas table(and i only have localhost in clients.conf and i only have one installed freeradius instance on the machine.).  As soon as i add a VR server to the config with just the most basic setup i can think of then requests starts getting rejected..

I guess it becomes duplicate clients because? Each VR server uses "readclients = yes" and nas_table = "nas" and they all use same NAS table and then the logic somehow checks each VR servers client readings with the already processed VR servers client list.

As i tried to say earlier i tried to do a workaround and let each VR server use its own NAS table and then it stopped complaining about duplicates.  But to add a NAS table for each VR server kind of makes it a bit annoying? But if that is how its suppose to be working now with 2.2.6 then i guess thats the way one have to do.
Anyway it still doesn't work to let any VR server read clients from each own NAS table..

I Don't know what the server should do..Maybe an easy fix is to only read the NAS table once at start and don't let the VR servers readings re-read the NAS table again unless the VR server actually is using another NAS table of course.

Anyway i will test your latest git 2.x.x again tomorrow and see if there is a difference.

Thank for  the answers. And have a lovely day.

Best regards

Från: Freeradius-Users [ at] för Alan DeKok [aland at]
Skickat: den 1 maj 2015 13:30
Till: FreeRadius users mailing list
Ämne: Re: reading hosts from NAS table not working on 2.2.6?

On May 1, 2015, at 12:51 AM, Alexander Silveröhrt <Alexander.Silverohrt at> wrote:
> Same problem after recompiling and installing freeradius-server-2.x.x. from git
> I guess? Since all clients got ignored for this VR server at start...

  It complains about duplicate clients.  The only reason to make that complaint is if you actually have duplicate clients.

  So... why do you have duplicate clients?  What configuration do you have, and what do you think the server should do?

> ###freeradius-server-2.x.x.
> /usr/local/lib/

  The code in v2.x.x git with the fix has a version of 2.2.9, so that may be an issue.

> Here is a log from a 3 VR server setup. First is working and reads the hosts from the NAS table the rest seems to be ignored

  Again, it's complaining about duplicate clients.  This is a problem.  You have to find out WHY it's complaining about duplicate clients, and go fix that.

  Why does the default configuration work, and your custom one fail?  What changes did you make?  Can you reproduce the problem with small changes to the default configuration?

  Alan DeKok.

List info/subscribe/unsubscribe? See

********* DISCLAIMER *********

This message and any attachment are confidential and may be privileged or otherwise protected from disclosure and may include proprietary information. If you are not the intended recipient, please telephone or email the sender and delete this message and any attachment from your system. If you are not the intended recipient you must not copy this message or attachment or disclose the contents to any other person

More information about the Freeradius-Users mailing list