FreeRADIUS 3.0.4 - Client fails to authenticate

Sotirios Tsiakeridis tsiakeridis.sotirios at
Sat Oct 17 19:53:57 CEST 2015

Hello, I am a student and currently studying the 802.1x standard. I am using FreeRADIUS 3.0.4 on Fedora for my studies.I also have a machine with Windows 10 as a supplicant and a Cisco 3550 as an authenticator. 
So far, I managed to configure what was needed to do some basic stuff. I am able to authenticate the client with a username/password combination using PEAP/MSCHAPv2. What I want to do now, is to authenticate using the same EAP method but with certificate credentials. I created the certificates successfully and sent the client certificate to the Supplicant to install. When I try to authenticate it produces the message "Failed to authenticate" on the Windows 10 machine. 
The Cisco 3550 debugging shows that it keeps sending an EAP-Request/Identity but with no answer as far as I understand. The radiusd -X command shows no packet received so I come to the conclusion that the Supplicant doesn't send anything for authentication. I tried using either a simple certificate selection or not in the settings with no difference. Shouldn't the Windows OS present me with a list of certificates to choose from, but I haven't done it before so I don't know what to expect.
I don't know how to proceed now, either the certificate I made is not correct or I didn't install it successfully. But I tried to follow many guides for that with no success. Could you help me. Thank you. 		 	   		  

More information about the Freeradius-Users mailing list