3.0.11 update broke my PEAP

Stefan Winter stefan.winter at restena.lu
Wed Feb 17 15:09:48 CET 2016


>> Indeed, there are two other virtual servers which have this without dash
>> (but I wouldn't know why!).
>   Then change all of them to MS-CHAP.  And it will work.

Well I now changed all of them consistently to MSCHAP, and confirm that
this works.

I guess I could alternatively change all of them to MS-CHAP and it would
still work.

I still can't get my head around this... if the name doesn't matter,
could I consistently change it to Auth-Type FOOBAR{} and it would still

Or are both MSCHAP and MS-CHAP two reserved words for essentially the
same thing, and using both in the same config now (as in 3.0.11+) yields
unexpected results? And the unexpected results are the "correct" results?

>   I'm saying that the configuration never really did what you expected.  It "worked", for accidental versions of "worked".

The subtlety of why it's wrong is too subtle for me. It worked for an
incredibly long time over many many versions. And if the two keywords
can't co-exist in the same config then this doesn't seem documented


Stefan Winter

Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et
de la Recherche
2, avenue de l'Université
L-4365 Esch-sur-Alzette

Tel: +352 424409 1
Fax: +352 422473

PGP key updated to 4096 Bit RSA - I will encrypt all mails if the
recipient's key is known to me

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20160217/34e6ea7b/attachment.sig>

More information about the Freeradius-Users mailing list