Make file error on Solaris

Alan DeKok aland at
Wed Jan 27 15:52:26 CET 2016

On Jan 27, 2016, at 9:45 AM, Marco <marco.xp at> wrote:
> i trying to install the Freeradius Server v3.0.11 on the Solaris 5.10 spare

  It worked when I tried it.

> i have installed latest gnu release of the grep and awk tools,
> i've also listed their paths on the first position of the PATH to set these as default tools

  Are you sure?  What does it say when you do:

$ which grep

> Starting from a fresh installation, these are the steps:
> # ./configure --prefix=<install-dir>
> (this seems completed with minor warnings)
> # gmake
> CC jlibtool.c
> HEADER src/include/attributes.h
> /bin/sh: ATTRIBUTE: not found
> Usage: grep [OPTION]... PATTERN [FILE]...
> Try 'grep --help' for more information.

  That looks like it's using the Solaris grep.

> /bin/sh: VALUE: not found
> Usage: grep [OPTION]... PATTERN [FILE]...
> Try 'grep --help' for more information.
> HEADER src/include/features.h
> /bin/sh: s,#[\\t ]*ifdef[\\t ]*" $2 "$,#if "$3 ",g;s,#[\\t ]*ifndef[\\t
> ]*" $2 "$,#if !"$3 ",g;s,defined(" $2 ")," $3 ",g;"}: not found

  And the Solaris sed.

> any advice?

  Be sure you're using the correct grep / sed.

  I tried the Solaris fixes before committing them.  So it *does* work.

  Perhaps the next step is to look for a Solaris "grep", and refuse to run if so.

  Alan DeKok.

More information about the Freeradius-Users mailing list