rotating detail files

Jakob Hirsch jh at
Mon Jun 20 16:48:22 CEST 2016

A.L.M.Buxey at wrote on 2016-06-20 15:18:
>>> /etc/freeradius/sites/control-socket[23]: No address specified in listen section
> not sites-enabled   path? what have you been doing to your config?

only replaced
  $INCLUDE sites-enabled/
in radiusd.conf with
  $INCLUDE sites/

config is deployed automatically, so there's no need to have
sites-available and create symlinks in sites-enabled. Should really make
no difference.

> works here:
> listen {
> 	type = control
> 	socket = ${run_dir}/${name}.sock
> 	uid = radiusd
> 	gid = radiusd
> 	mode = rw
> }

I already tried this (any many variants), with no success.

This is plain 3.0.11, right, with no patches applied? Very strange. It
behaves as I have type = auth or acct, but I don't see how this could

> ensure that the server has permissions to write to that ${run_dir} path?

I even tried /tmp/sock etc. Using strace, I don't see a syscall trying
to use run_dir...

More information about the Freeradius-Users mailing list