Specifying NAS-IP-Address in eapol_test CLI

Alex Sharaz alex.sharaz at york.ac.uk
Wed Jun 29 18:02:30 CEST 2016

o.k. the man page isn't very helpful

I want to pass a value for NAS-IP-Address to eapol_test as an argument.

the man page says

-N attr spec
 Send  arbitrary  attribute specific by attr_id:syntax:value, or attr_id
alone.  attr_id
              should be the numeric ID of the attribute, and syntax should
be one  of  's'  (string),
              'd'  (integer),  or 'x' (octet string). The value is the
attribute value to send.  When
              attr_id is given alone, NULL is used as the attribute value.
Multiple  attributes  can
              be specified by using the option several times.

so I wanted to pass as the NAS-IP-Address

I've tried
eapol_test -c /usr/local/etc/peap-ydh.conf -A -a -s <key> -N 61:d:15 -N 6:d:8 -N 4:s:

but that gives me

Attribute 4 (NAS-IP-Address) length=16
      Invalid IP address length 14
Putting the address in quotes makes no difference other

even tried -N 4:x:061064064056063062056061062066054061063071

which should be in octal

Still got an invalid IP address Length

Any Ideas?

More information about the Freeradius-Users mailing list