Small issue with buffered-sql

Alan DeKok aland at
Fri Nov 25 13:42:13 CET 2016

On Nov 25, 2016, at 5:23 AM, Alex Sharaz <alex.sharaz at> wrote:
> Initially I replaced the -sql statements in my inner-tunnel virt server
> with a call to detail  and that worked just fine. I then tried to the same
> thing with my "default" virtual host so that proxied auths for visiting
> eduroam users would use buffered-sql as well.  As soon as I did this (this
> was trying to use buffered sql for post-auth and accounting packets
> although the file continued to grow, it never came down.

  Then read the debug output to see what's going on.

> Looking at contents of, the 1st thing I noticed was that while
> Authentication packets had a Packet-Type = Access-Request just after the
> timestamp, Accounting packets didn't have a Packet-Type attribute.

  That's fine.

> Should I be able to use buffered-sql to process accounting packets?

  The documentation says so.  We don't intentionally lie in the documentation.

  Alan DeKok.

More information about the Freeradius-Users mailing list