Using radtest on port 1645

Brett Glasson Brett.Glasson at
Thu Feb 23 04:44:56 CET 2017

From: Freeradius-Users < at> on behalf of Adam Bishop <Adam.Bishop at>
Sent: Thursday, 23 February 2017 2:29 PM
To: FreeRadius users mailing list
Subject: Re: Using radtest on port 1645

> On 23 Feb 2017, at 03:17, Brett Glasson <Brett.Glasson at> wrote:
> > Note the part where radtest has ignored the provided port 1645 and has gone ahead and used 1812 anyway, although the NAS-Port is (correctly shown as being 1645 later on.

> The NAS-Port attribute and the UDP port used by FreeRADIUS aren't the same thing - NAS port is a hint to the RADIUS server about (if you were using a wired NAS) which
>  physical port has a wire hanging out of it.

> You need to append :1645 to send the request to a different UDP port, e.g.:
>  $ radtest test testpass 10 testing123

OK, thanks Adam! I had tried before but I had just replaced the space in 1645 with a colon.which meant that I'd left off the NAS port so I only got a syntax error for my trouble.

After adding the NAS port back as well it worked perfectly.

I guess I was thrown by the fact that my original command worked OK on the older server.

Anyway, once again, thanks!


More information about the Freeradius-Users mailing list