MySQL DB and /n in Cisco-AVPair problem

Alan DeKok aland at
Thu Jul 20 19:36:10 CEST 2017

On Jul 20, 2017, at 10:07 AM, Andy Smith <a.smith at> wrote:
> I was using the radclient from a Linux desktop, which was version 2.2.8,
> for testing against both the 1.x server and the 3.0.14.

  Your previous messages were talking about NTRadPing.  Please keep your story consistent.

> I've just tested
> again with the v3.0.14 radclient to both servers and I see the same
> thing, ie the response has a double escaped //n from the 1.x server but
> not the 3.0.14. 

  So?  As I've said, that's just debug output.

  As I've also said, what do the packets look like?  Have you tried using wireshark to compare the packets?

> I'm new to both the forum and FreeRadius. If this is still not the info
> needed please let me know what I should be providing, 

  It's nice that you're new.  It's annoying that you ignore the advice I've been giving.

  There are ways to get things done: follow instructions.

  There are ways to annoy people: do everything *other* than what you're told to do.

  So far you're about 75% ignoring advice, and 25% following it.  If you want to solve the problem, you have to change that ratio.  A lot.

  Alan DeKok.

More information about the Freeradius-Users mailing list