iOS mysterious issues on Freeradius 3.0.14

John Tobin jtobin at
Wed Mar 22 18:06:58 CET 2017

I am having the same problems, I run a tls/id-password 802.1x network at
East Stroudsburg University.
This is not easy research, since the error messages you receive no one
else seems to see.

My problem may be that apple devices are no longer accepting self signed
certs, but I have also looked at os x upgrades [home brew/openssl
problems] for openssl.
I am working all of this issue by issue.
I am still looking to resolve this, obviously it is not a ³bug² windows 7
and windows 10 is working.

My next problem is in finding a working 802.1x supplicant that works for
linux [SuSe / redhat-fedora].

It¹s like shoveling snow in a snow storm. You shovel a space clean, and
before you can turn around snow has blown, and fallen into the space again.
[Sorry, my back is reminding me of last weeks blizzard.]

Blessed are the meek, they will in herit the earth.
I have been working at this for months, one bug leads to the next.
I am looking at a very small inheritance.

Radiusd 3.0.11
Openssl 1.0.2-fips

I haven¹t even tried my iphone, I am still trying to get os x to work.


On 3/22/17, 11:37, "Freeradius-Users on behalf of Alan DeKok"
< at on
behalf of aland at> wrote:

>On Mar 22, 2017, at 7:39 AM, Igor Sousa <igorvolt at> wrote:
>> I've read a lot messages in Freeradius Forum and I continued
>> why iOS devices (iPhone, iPad) doesn't connect in my WPA-Enterprise wifi
>> network. I've installed and configured a freeradius server, version
>> over openssl 1.1.0e (both have installed from sources on Debian 8). I've
>> tested connect Android devices to my wifi network and everytime they can
>> connect to the network, but iOS devices have mysterious issues.
>  iOS may be magic... Apple doesn't talk to anyone else, so that doesn't
>> When I try connect iOS device to my wifi in first time, they can connect
>> perfectly. Though, if this same iOS device lost connection (because it's
>> out of range AP signal or air plane mode turn on by the user for 30
>> or hours) and try connect again the device doesn't connect.
>  Maybe it's related to session resumption?  Have you turned that off?
>> When I've saw
>> the debug mode, I've noticed that EAP-PEAP tunnel athentication was
>> successful and server sent Access-Challenge, but device doesn't answer
>> challenge. I don't understand why the android devices doesn't this
>  No idea.  I know that many, many, universities are using FreeRADIUS
>with iOS, so it *should* work.
>> Wed Mar 22 07:33:50 2017 : Debug: Waking up in 1.1 seconds.
>> Wed Mar 22 07:33:50 2017 : Debug: (17) Received Access-Request Id 8 from
>> to length 255
>  PLEASE follow the instructions, and use "radiusd -X".  Doing "-Xx" just
>makes the debug output harder to read.
>  Alan DeKok.
>List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list