Radius crashing with "Failed adding event handler for socket: Too many readers"

Alan DeKok aland at deployingradius.com
Mon Apr 30 13:18:43 CEST 2018

On Apr 29, 2018, at 11:58 PM, Campbell McKenzie <Campbell.McKenzie at aarnet.edu.au> wrote:
> Upon using the packages from packages.networkradius.com (3.0.16)
> We are still getting the issue where the radius server will exit(1) with the last 
> logged line being:
> " radiusd[13056]:Failed adding event handler for socket: Too many readers" 
> We are no longer using "src_ipaddr" as previously mentioned... but still
> the same error as when we used it previously? 

  It depends on what your configuration does.  If it worked before and now doesn't work, what changed?

  The v3.0.16 on the server is exactly the same source that would be installed from anywhere else.w

> The only thing I can think of next is weird interactions between 
> Freeradius and dummy interfaces (/usr/sbin/ip link add any0 type dummy)
> producing similar behavior to "src_ipaddr" in regards to UDP sockets? 

  FreeRADIUS doesn't care about ethernet interfaces.

> Any thoughts on this? Or how I can continue to troubleshoot?

  Use 3.0.17, as it has some issues fixed.  And, describe what you're doing.  Normal configurations don't run into this, so you're doing something unusual.

  Alan DeKok.

More information about the Freeradius-Users mailing list