Alan DeKok aland at
Thu Aug 29 19:18:18 CEST 2019

On Aug 29, 2019, at 1:01 PM, Munroe Sollog <mus3 at> wrote:
> I'm trying to enable tls caching on my radius server.  the radius -X output
> is included below.  I'm also including some additional information for
> reference.  Looking at the debug output I see where the cache config is
> loaded and it looks right to me.  I don't see any errors around it.
> I'm expecting to see a file in the tlscache folder after a successful auth,
> however the folder remains empty.
> # freeradius -v
> radiusd: FreeRADIUS Version 3.0.17, for host x86_64-pc-linux-gnu, built on
> Apr 22 2019 at 21:23:36
> FreeRADIUS Version 3.0.17

  My $0.02 is to grab the v3.0.x branch from GitHub:

  I know that the TLS cache worked at one point.  But when I tried using it recently, I found issues.  After some poking, the easiest thing to do was to update the code, docs, and examples.

  See the "cache" section of mods-available/eap in the file that's in GitHub

  Alan DeKok.

More information about the Freeradius-Users mailing list