failed linking to libcrypto error during compilation from source

Alan DeKok aland at
Thu Jun 20 13:12:17 CEST 2019

> On Jun 20, 2019, at 12:12 AM, Tal Nur via Freeradius-Users <freeradius-users at> wrote:
> Hi all,
> I tried to compile FR from source on my Ubuntu 18.04 server according  the instructions on I run ./configure command I got error:                failed linking to libcrypto error

  What are the *rest* of the errors?  There are usually additional errors, like "library not found", or "unknown symbol", etc.

  Please don't post summaries of complex problems.  It's much more productive to copy the *actual* errors to the list.

> I found the location of And run again ./configure command with explicit path to
>              ./configure  --with-openssl-lib-dir=/usr/lib/x86_64-linux-gnu/But I got again the same error message:             failed linking to libcrypto error
> How can I fix the problem?

  Without more information, it's impossible to say.

  The build system uses tools from your OS in order to link libraries.  So if linking libraries doesn't work, it's generally the fault of the tools in your OS.

  Alan DeKok.

More information about the Freeradius-Users mailing list