Help with Freeradius/freeradius-server Docker Container

Reuben Fischman Fischmanr at
Mon Mar 11 21:55:10 CET 2019

> Just tried it. Seems to work. You are right in that it does not show 
> much log information, but you can check whether the server is running by 
> executing "ps auxw" inside the container
> docker exec -ti my-radius ps aux

That's kind of the problem..  The docker container starts and immediately dies so I can't connect to the container.

I DID run in debug mode with -X at the end as was suggested.  The container still starts and immediately exits.

Command I'm executing is:
"docker run --name my-radius -d freeradius/freeradius-server -X"

After the container dies, I run a "docker container logs my-radius" and get a fair amount of output as the container goes through the startup process.  It ends with the following lines:
"Failed opening auth address :: port 1812 bound to server default: Address family not supported by protocol
/etc/freeradius/sites-enabled/default[245]: Error binding to port for :: port 1812

It's as if something is already bound to port 1812 within the container.  There are no other radius services running on the docker host

This docker host is ubuntu 18.04.  As a test, I tried to load the container on my synology NAS and it DOES start up with no problem using the same command as above.

Not sure what's misconfigured on my ubuntu system.  Any ideas/assistance are appreciated.

More information about the Freeradius-Users mailing list