Compilation Issue

Nicolas Breuer Nicolas.Breuer at
Fri May 3 11:39:05 CEST 2019

For the Community :

We found the issue, that was not linked to compiler / distri / gcc / librairies broken or something like that.

The ./configure found an old library of lib-pcap (0.9) and used that library. That caused "the make" to crash.
Removing the entire directory solved all problems -> without libpcap, radius sniffer module was disabled and compiling was done in 2 minutes.

-----Message d'origine-----
De : Freeradius-Users < at> De la part de Alan DeKok
Envoyé : jeudi 2 mai 2019 14:32
À : FreeRadius users mailing list <freeradius-users at>
Objet : Re: Compilation Issue

On May 2, 2019, at 7:56 AM, Nicolas Breuer <Nicolas.Breuer at> wrote:
> Hello Alan,
> Don't worry 😊 I want to try to build it on my server;

  Then fix your server so that it can compile programs.

> Indeed I can build it on an other Centos 6 but I still have this compile error on my "first" server.
> I already tried to reinstall gcc, glibc*, etc. 
> Any ideas what others packages can cause this ?
> Stdlib.h is part of glibc-headers.

  Ask the gcc / glibc people why their headers are broken.

  You'll get the same answer I gave you: upgrade.

  Use a modern OS.  Or, fix it yourself.

  Newer versions of CentOS and GCC are free to download and use.  There's no reason to ask us to pay the cost for your decision to use something that's wildly out of date.

  This issue is off topic for the FreeRADIUS list.  Stop asking questions about problems that you created, and that you can fix.

  Alan DeKok.

List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list