Freeradius 3.0.15 failing to read server.pem file

Chris Bradley bradleyc at
Fri May 17 19:06:45 CEST 2019

The plot thickens. So, I tried different things like using the 'make' commands I found in history from when I first setup the servers, etc. Tried deleting server.pem and re-creating. Always ending with the same error.

In our environment we have 2 servers running Freeradius (Ubuntu 14) that authenticate certificates for staff wireless (primary) and backup) and two that authenticate certificates for our student wireless. The secondary for students has been broken for awhile now and I haven't had the need to fix it.

Anyway, we took one of the working staff freeradius servers and cloned it (VM). Then, we removed the /etc/freeradius/certs directory from the clone (actually renamed it) and replaced it with the /etc/freeradius/certs directory from our broken server. 

It's working great. =-\

So, was freeradius itself broken somehow or just some oddball thing is out of whack with the OS and we might never know what really happened?
>>> "Chris Bradley" <bradleyc at> 5/17/2019 10:43 AM >>>
Thank you, Alan!

Found it! The password is correct in the eap file.

How do I go about re-generating the private key & certificate as you mentioned before?
>>> Alan DeKok <aland at> 5/17/2019 10:30 AM >>>
On May 17, 2019, at 10:22 AM, Chris Bradley <bradleyc at> wrote:
> I'm trying to remember where to look for the password in the eap module configuration. I'm guessing at this point that it's in clients.conf?

  No, it's in the EAP module configuration.  mods-available/eap.  Look for "password".

> Sorry, it's been almost 2 years since I set this up and tinkered with it.
> Question for you and the group. If we did Ubuntu updates on this server, could that have broken the freeradius configs/functionality?

  It might have changed OpenSSL.  Which then might change things.  But it's hard to say.

  It won't have changed the FreeRADIUS configuration.

  Alan DeKok.

List info/subscribe/unsubscribe? See

List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list