Unable to create control socket

Alan DeKok aland at deployingradius.com
Sun Apr 26 23:45:09 CEST 2020

On Apr 26, 2020, at 9:31 AM, email.me at kevp.com wrote:
> Can anyone please help me get the control socket for radmin working on
> Ubuntu.
> I've built FreeRADIUS v3.0.21 debs from source and install the debs on
> Ubuntu 18.04.
> I then created some ssl certs and the default config starts up ok.

  That's good.

> I then add a symlink to turn on the control-socket and sudo freeradius -X
> gives the error:
> Failed creating control socket "/var/run/freeradius/freeradius.sock": Failed
> creating control socket directory: Permission denied

  Are you running it as root?  If so, you shouldn't get a permission denied error.

  if you're running it as "radiusd", ensure that the /var/run/freeradius/ directory exists, and is writeable by user "radiusd".

> I know the service startup has comments about the directory creation not
> working on Ubuntu Bionic (18.04).

  Where are this comments?

> So I've tried creating /usr/lib/tmpfiles.d/freeradius.conf containing: 'd
> /var/run/freeradius 0755 freerad freerad -'
> Ran sudo systemd-tmpfiles --create but no /var/run/freeradius

  That seems an issue for systemd, then.

> Rebooted and no /var/run/freeradius

  Systemd typically deletes /var/run on every reboot.

> sudo freeradius -X gives same error (as above).
> Anyone know how to get the control-socket to start correctly on Bionic?

  Create the directory with the correct permissions before you start FreeRADIUS.

  Or, start it as "root", but with uid/gid set in the configuration files.  It should then create the directories itself, and set the right permissions.

  Alan DeKok.

More information about the Freeradius-Users mailing list