MEjaz mejaz at
Mon Sep 7 16:47:36 CEST 2020

Thanks for the information 

Thanks for your tips, 


As advised, I have tried set the MSSQL driver in SQL  file but when I set this,  ran into different problem with  "could not link driver rlm_sql_mssqlo" 
Whereas I have successfully  installed this MS-tools and I have made sure as below. 

[root at radius-1 ~]# rpm -qa | grep odbc
[root at radius-1 ~]# rpm -qa | grep -i unix

would this be enough or do we need to install any other dependencies. Please assist. 

Could not link driver rlm_sql_mssql: /usr/local/lib/ cannot open shared object file: No such file or directory
Make sure it (and all its dependent libraries!) are in the search path of your system's ld
/usr/local/etc/raddb/mods-enabled/sql[2]: Instantiation failed for module "sql"


-----Original Message-----
From: Freeradius-Users [ at] On Behalf Of Alan DeKok
Sent: Monday, September 7, 2020 2:57 PM
To: FreeRadius users mailing list <freeradius-users at>
Subject: Re: auth-type-error

On Sep 7, 2020, at 4:58 AM, MEjaz <mejaz at> wrote:
> I am trying to configure FreeRadius 3.0X  with remote MSSQL and 
> unixODBC, all basic tests have been passed sucefully.

  You need to configure the "sql" module, to set "dialect", and maybe "driver".  This is documented in the comments in mods-available/sql.
> However, when I run radtest, on my radiusd server, I get the following 
> error ...
> [root at radius-1 ~]#  radtest testnesma at 112233 
> localhost 0 testing123

  We do NOT need to see the output of "radtest".  This is documented everywhere.

> ...
> The 'rlm_sql_null' driver CANNOT be used for SELECTS.
> Please update the 'sql' module configuration to use a real database.
> Set 'driver = ...' to the database you want to use.

  That seems pretty clear.

  It helps to read the comments in the module, and the debug messages that the server produces.

  Alan DeKok.

List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list