EAP Submodule failed. PAM module issue.

Alan DeKok aland at deployingradius.com
Thu Sep 17 02:22:35 CEST 2020


On Sep 16, 2020, at 7:05 PM, HORMAZABAL PI´┐ŻONES BARBARA FRANCISCA <bhp001 at alumnos.ucn.cl> wrote:
> 
> I apologize for the late reply. So I couldn't find a way to fix it and
> ended up trying to redo it all over again, re-installing freeradius and
> all. However, whenever I try to compile the module there is an
> incompatibility problem. Turns out this module and any other module I have
> looked for that authenticates against gmail is obsolete with freeradius 3.

  So... which modules are those?  It would help to say what they are.

  The server doesn't include a module to authenticate against gmail.  if there are third-party modules, well, we don't know anything about them.

  I really wish that people would submit their modules back to us.  That way everyone could benefit from their work.

> The modules work only for version 2, I tried setting up freeradius 2 but I
> have another error with installing with the make and make install modules
> so that's another thing out of the question.

  "i did stuff and an error happened".

  Please read the docs for how to ask GOOD questions:

http://wiki.freeradius.org/list-help

> Is there any other way to authenticate against gmail in freeradius 3?

  Use a Perl or Python script.

  Alan DeKok.




More information about the Freeradius-Users mailing list