EAP Submodule failed. PAM module issue.

Alan DeKok aland at deployingradius.com
Thu Sep 17 21:06:16 CEST 2020


On Sep 17, 2020, at 2:12 PM, HORMAZABAL PI´┐ŻONES BARBARA FRANCISCA <bhp001 at alumnos.ucn.cl> wrote
>> That's small enough that it should be trivial to port it to v3.
> Sorry if it's trivial but how can I do this?

  You need to know C.

>> You didn't run "configure" before running "make".  The documentation says
> to do this.
> I did run configure and then make and make install. I was reading the
> documentation while doing this. However a different error appeared today
> when doing the process again:
> 
> eap_tls.c:132:28: error: dereferencing pointer to incomplete type 'SSL
> {aka struct ssl_st}'
>            tls_session->ssl->session);
>                            ^~

  Hmm... you're using a newer version of OpenSSL.  Oh well.  v2 isn't supported, and hasn't been updated for newer versions of OpenSSL.

  Alan DeKok.




More information about the Freeradius-Users mailing list