rlm_peap.so Error

Alan DeKok aland at deployingradius.com
Wed Jun 9 11:39:20 CEST 2021

On Jun 8, 2021, at 8:58 PM, Tal Nur via Freeradius-Users <freeradius-users at lists.freeradius.org> wrote:
> I installed FR 3.0.22 on Ubuntu 20.04 from package and edit eap file because default_eap_type was md5, I changed it to peap.

  You changed more than that, though.  It helps to accurately describe what you've done.

> But when I run FR in debug mode: 
> #sudo freeradius -X I got the error message:
>  Failed to link to module 'rlm_peap': /usr/lib/freeradius/rlm_peap.so: cannot open shared object file: No such file or directory

  Read ALL of the error messages.  The lines you didn't post show which file and line number are causing the problem.

  You've added "peap" to something in raddb/sites-enabled/.  Don't do that.

> I checked /usr/lib/freeradius directory and really didn’t find rlm_peap.so file, but I found rlm_eap_peap.so instead.


  PEAP is used and loaded by the EAP module.  You need to use "eap" in the virtual servers, not "peap".

  i.e. if you had just taken the default configuration and changed

	default_eap_type = md5


	default_eap_type = peap

  Then it would have worked.  The other changes you made ended up breaking the server.  Don't do that.

  Alan DeKok.

More information about the Freeradius-Users mailing list