Error binding to port for port 1812 | address already used

Alan DeKok aland at
Mon Sep 26 11:59:02 UTC 2022

On Sep 26, 2022, at 4:36 AM, Steven Walters <steven.walters1 at> wrote:
> I upgraded to FreeRADIUS Version 3.2.0 and still have the same error
> message.
> Nothing bound to port 1812.

  The OS doesn't lie.

  If nothing else is running, then you've broken your configuration.  You have multiple "listen" sections which use the same IP/port.

  You previously said:

>> We are running multiple virtual servers on the same port 1812 and 1813.
>> the "ipaddr = *" set in all site configurations.

  That never worked.  The server might have started with that configuration, but it never did anything useful.

  Don't run multiple virtual servers on the same IP/port.  It doesn't work.  It never worked.

  When the system receives a packet for that IP/port, the OS will randomly send the packet to one socket.  It will NOT send all packets to all sockets.  It will NOT send packets from one client consistently to one socket.

  Fix your configuration so that it's correct.

> On Sat, 24 Sept 2022 at 14:00, <
> freeradius-users-request at> wrote:

  Please edit your posts to remove useless text.  There is no reason to post the ENTIRE digest to the list, for a 15 line-reply.

  Alan DeKok.

More information about the Freeradius-Users mailing list