accounting on msql

Alan Buxey A.L.M.Buxey at
Mon Mar 15 18:11:17 CET 2010


> just want to manage accounting on mysql
> so i coyed the schema.sql in /etc/freeradius,
> did mysql -u root -p accounting < schema.sql
> and i got this.
> ERROR 1064 (42000) at line 17: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '[radacct] (
>     [RadAcctId] [numeric](21, 0) IDENTITY (1, 1) NOT NULL ,
>     [AcctSessi' at line 1

that'd be the Microsoft SQL you've tried using (mssql)

> i compare the schema.sql  to one at , nothing changed.

I repeat...that'd be mssql you've just tried using, NOT MySQL.

if you want to use MySQL, then please use the MySQL schema, the MySQL commands
and please follow the MySQL documentation. 

not sure where your schema woudl by lying around on you OS... but you can easily grab it from the
source - its in the radd/sql/mysql/ directory and has the following line near the top

#     Database schema for MySQL rlm_sql module                            #

..then simply use the dialup.conf etc (basically, configure sql.conf and add/uncomment
the relevant lines in the default and inner-tunnel virtual servers)


More information about the Freeradius-Users mailing list