Freeradius says it is listening on port 1812, but isn't

Matt Harlum matt at
Wed Mar 24 09:51:02 CET 2010


I'm running Freeradius 2.1.6 on MacOSX 10.5.7 on a Dual-G4 867Mhz PowerMac

Since march last year I've had 2.1.6 installed however it's been switched off for the last few months.
Recently I powered it back on and have run system updates etc and got to the point I am now

When I launch FreeRadius it says it is listening on *:1812 for auth however my AP is unable to connect, and trying telnet on port 1812 results in "Connection Refused"

I've tried reverting the configuration to default but it hasn't worked. running radiusd -x does not throw any errors

Listening on authentication address * port 1812
Listening on accounting address * port 1813
Listening on command file /usr/local/var/run/radiusd/radiusd.sock
Listening on proxy address * port 1814
Ready to process requests.

Anyone have any ideas as to why this would be happening all of a sudden? perhaps the system updates broke it?

Matt Harlum

More information about the Freeradius-Users mailing list