Freeradius says it is listening on port 1812, but isn't

Nicolas Goutte nicolas.goutte at
Wed Mar 24 09:59:26 CET 2010

Am 24.03.2010 um 09:51 schrieb Matt Harlum:

> Hi,
> I'm running Freeradius 2.1.6 on MacOSX 10.5.7 on a Dual-G4 867Mhz  
> PowerMac
> Since march last year I've had 2.1.6 installed however it's been  
> switched off for the last few months.
> Recently I powered it back on and have run system updates etc and  
> got to the point I am now
> When I launch FreeRadius it says it is listening on *:1812 for auth  
> however my AP is unable to connect, and trying telnet on port 1812  
> results in "Connection Refused"
> I've tried reverting the configuration to default but it hasn't  
> worked. running radiusd -x does not throw any errors
> Listening on authentication address * port 1812
> Listening on accounting address * port 1813
> Listening on command file /usr/local/var/run/radiusd/radiusd.sock
> Listening on proxy address * port 1814
> Ready to process requests.
> Anyone have any ideas as to why this would be happening all of a  
> sudden? perhaps the system updates broke it?

Have you checked firewalls and such? Perhaps you can also check with  
tools like tcpdump if the packets arrive on the computer where  
freeradius is running.

Also perhaps check that the computer has really the IP address or name  
that you think it has and that the IP or name is really used by the AP.

> Regards,
> Matt Harlum
> -
> List info/subscribe/unsubscribe? See

Have a nice day!

Nicolas Goutte

extragroup GmbH - Karlsruhe
Waldstr. 49
76133 Karlsruhe

Geschäftsführer: Stephan Mönninghoff, Hans Martin Kern, Tilman Haerdle
Registergericht: Amtsgericht Münster / HRB: 5624
Steuer Nr.: 337/5903/0421 / UstID: DE 204607841

More information about the Freeradius-Users mailing list