Freeradius says it is listening on port 1812, but isn't

Fajar A. Nugraha fajar at
Wed Mar 24 10:21:24 CET 2010

On Wed, Mar 24, 2010 at 3:51 PM, Matt Harlum <matt at> wrote:
> Hi,
> I'm running Freeradius 2.1.6 on MacOSX 10.5.7 on a Dual-G4 867Mhz PowerMac
> Since march last year I've had 2.1.6 installed however it's been switched off for the last few months.
> Recently I powered it back on and have run system updates etc and got to the point I am now
> When I launch FreeRadius it says it is listening on *:1812 for auth however my AP is unable to connect,

"unable to connect" is the result. Many things can cause it, from
incorrent radius IP/secret settings on AP to firewalls blocking

> and trying telnet on port 1812 results in "Connection Refused"

you can't test UDP with telnet. Try the included radtest and radclient

> I've tried reverting the configuration to default but it hasn't worked. running radiusd -x does not throw any errors

does it print incoming packets and process it?
does tcpdump (or whatever packet capture tools you have) shows incoming packets?


More information about the Freeradius-Users mailing list