Problems with radzap: radclient:: failed to get value

Alan Buxey A.L.M.Buxey at
Tue Dec 20 00:03:35 CET 2011

> Hash: SHA1
> I'm trying to run a radzap and having no luck.  For example, if I try:
>    radzap -d /etc/raddb -N $NAS_IP -P 1 -u las $NAS_IP $NAS_PW
>    radclient:: failed to get value
>    radclient: Nothing to send.
> I've also tried it with the NAS name ("52a2", from /etc/raddb/naslist)
> rather than IP:
>    radzap -d /etc/raddb -N $NAS_IP -P 1 -u las 52a2 $NAS_PW
>    radclient: Failed to find IP address for host 52a2: Success
> If I run radwho:
>    radwho -ZR -N -P 1 -u las

man radzap

 radzap [-d raddb_directory] [-h] [-N nas_ip_address] [-P nas_port] [-u user] [-U user] [-x] server[:port] secret

you talk to the server using the servers secret....not the NAS with the NAS secret, so send
a radzap command to your FR server with its secret from the session you are on (eg on localhost thats testing123 by default..)


More information about the Freeradius-Users mailing list